Results 1 to 7 of 7

Thread: Flash cart question for Scott, or whoever has an opinion.

  1. #1
    actionmunky Guest

    Default Flash cart question for Scott, or whoever has an opinion.

    I have had an R4 card for a while with my DS lite and really enjoy the convenience of having all my games on one cart. However since I got my DSIXL it will no longer work and is not upgradeable. In your opinion, what is the best and most compatible flash cart that will work with the 1.4.3u DSIXL and also upgradeable so it will work with future update and the 3DS.
    Thanks.

  2. #2
    actionmunky Guest

    Default

    So....no one has an opinion on this?

  3. #3
    Join Date
    Mar 2010
    Location
    Petersburg, IN
    Posts
    1,050

    Default

    I use an r4 gold in my 3ds. Working fine so far, and I have a ds lite to do firmware updates too.

    Sent from my VM670 using Tapatalk

  4. #4
    Join Date
    Jan 2009
    Location
    Lancashire, UK
    Posts
    4,392
    Blog Entries
    45

    Default

    The trouble with the DSi onwards is that Nintendo can send out firmware updates which kill whatever card you're using, so if you go with one that works today, it may not work tomorrow.

    The 3DS has cards that currently work I believe for DS games but not 3DS games but I would always be conscious that they would kill it with an update. The other thing to consider is that even if you ignore updates when they are sent out, a game will come along that requires it like Mario Kart Wii did so you have to upgrade to play it and your card stops working in the process.

    Until there is a hardware hack out for the 3DS that allows cards to continue working or allows you to play games without updating firmware you are taking a risk.

    I keep my DS Lite for this very reason. I only play original games on my 3DS and carry those 3 games with me.
    Before you insult a man, walk a mile in his shoes. That way, when you insult him, you'll be a mile away, and have his shoes.
    Jamesonline.net
    RetroGaming RoundUp
    Follow us on Facebook

  5. #5
    actionmunky Guest

    Default

    Yeah I agree that is is definitely more of a pain now because of updates. Is there a card that allows you to update the firmware of the card itself so they can adapt to nintendo's updates? Last I heard the Acekard 2 worked with dsixl but I'm not sure if it's updateable.

  6. #6
    Join Date
    Jan 2009
    Location
    Lancashire, UK
    Posts
    4,392
    Blog Entries
    45

    Default

    I haven't kept up with the developments tbh.

    I use a CycloDS on my DSLite which is updatable and others in the house have the R4 which is also updatable but is no longer the best option.

    From what I heard the best bet at this stage I think is the Acekard.
    Before you insult a man, walk a mile in his shoes. That way, when you insult him, you'll be a mile away, and have his shoes.
    Jamesonline.net
    RetroGaming RoundUp
    Follow us on Facebook

  7. #7

    Default

    R4-3DS is a cart that is compatible with all makes of DS and the 3DS for DS games. It is more likely to have updates to still work when Nintendo muck about with the firmware to stop it. However, you might want to hold off on using carts with the 3DS as it could get bricked (very unlikely) or you could get banned from online play and have your warranty voided (possible). If you have an ambassador version (bought before the price cut and eligible for free game downloads, this could be significant.

    I'd do what UK Mike does and have a cheap DS along side the 3DS.

Members who have read this thread: 0

There are no members to list at the moment.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Retro Gaming RoundUp